Author Topic: NHD-0216CW-AB3 dots underneath characters  (Read 2232 times)

cprobert

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
NHD-0216CW-AB3 dots underneath characters
« on: November 19, 2015, 10:26:39 AM »
I've got this screen set up using SPI at 3.3V an it seems to be working other than I get a single row of dim pixels underneath the characters. If I stop writing to the display the dots go away and just show the static characters. As the characters change I get a different arrangement of dim dots.

I am writing to the display every 40mS and showing a changing value.

I have tried slowing the clock down to 500Khz but no effect. My SPI timings seem to match the US2066 data sheet.

Any suggestions to fix this would be gratefully received.

 

Character LCD NHD‐0220D3Z‐NSW‐BBW‐V3 not receiving correct characters

Started by davekBoard Character LCDs

Replies: 1
Views: 3891
Last post March 25, 2016, 05:23:05 PM
by Saurabh_B
NHD‐240128WG‐BTFH‐VZ - custom characters

Started by saubaerBoard Graphic LCDs

Replies: 1
Views: 2729
Last post November 11, 2016, 12:09:42 PM
by Saurabh_B
NHD-2.7-12864UCY3 yellow columns occur under ascii characters

Started by bsoyerBoard OLEDs

Replies: 7
Views: 6230
Last post August 26, 2015, 11:02:25 AM
by tracyb
NHD-C0220BiZ-FSW-FBW-3V3M NAKs all odd numberd ASCII characters

Started by majorninthBoard Character LCDs

Replies: 7
Views: 5848
Last post May 28, 2015, 04:51:31 PM
by Michael_L
NHD-0420E2Z-NSW-BBW is displaying Japanese Characters instead of my string

Started by shaneyostBoard Character LCDs

Replies: 1
Views: 6505
Last post June 03, 2014, 10:11:25 AM
by Michael_L