Author Topic: NHD-0216CW-AB3 dots underneath characters  (Read 1792 times)

cprobert

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
NHD-0216CW-AB3 dots underneath characters
« on: November 19, 2015, 10:26:39 AM »
I've got this screen set up using SPI at 3.3V an it seems to be working other than I get a single row of dim pixels underneath the characters. If I stop writing to the display the dots go away and just show the static characters. As the characters change I get a different arrangement of dim dots.

I am writing to the display every 40mS and showing a changing value.

I have tried slowing the clock down to 500Khz but no effect. My SPI timings seem to match the US2066 data sheet.

Any suggestions to fix this would be gratefully received.

 

Character LCD NHD‐0220D3Z‐NSW‐BBW‐V3 not receiving correct characters

Started by davekBoard Character LCDs

Replies: 1
Views: 2736
Last post March 25, 2016, 05:23:05 PM
by Saurabh_B
NHD‐240128WG‐BTFH‐VZ - custom characters

Started by saubaerBoard Graphic LCDs

Replies: 1
Views: 1677
Last post November 11, 2016, 12:09:42 PM
by Saurabh_B
NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue

Started by forteyBoard OLEDs

Replies: 14
Views: 8553
Last post March 09, 2015, 02:23:51 PM
by Retheesh_M
NHD-2.7-12864UCY3 yellow columns occur under ascii characters

Started by bsoyerBoard OLEDs

Replies: 7
Views: 4830
Last post August 26, 2015, 11:02:25 AM
by tracyb
NHD-C0220BiZ-FSW-FBW-3V3M NAKs all odd numberd ASCII characters

Started by majorninthBoard Character LCDs

Replies: 7
Views: 4497
Last post May 28, 2015, 04:51:31 PM
by Michael_L