Author Topic: NHD-0216K1Z-NSW-BBW6L contrast problem  (Read 28 times)

bidbid21

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
NHD-0216K1Z-NSW-BBW6L contrast problem
« on: December 12, 2017, 02:34:57 AM »
Hi,
Actually, I have a problem with display NHD-0216K1Z-NSW-BBW-L.
After about one mouth for use, the contrat of this does not work anymore.
Half charactere are displayed and se screen twinkles.
Do you have a solution?
Thanks

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 363
  • Karma: 10
    • View Profile
Re: NHD-0216K1Z-NSW-BBW6L contrast problem
« Reply #1 on: December 12, 2017, 08:04:33 AM »
Would it be possible to send a picture of what you are seeing.

Also what temperature is the display used in, and what is the voltage on the display?

bidbid21

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0216K1Z-NSW-BBW6L contrast problem
« Reply #2 on: December 12, 2017, 09:23:20 AM »
Actually, the voltage of display is 5v(by 7805 regulator) and contrast 0.9v (by the tension divider bridge between 5v and ground)
I saw that the stikers on the chip has browned.
The display was use in building (ambient temperature)
burned stickers
display after set V0 to Ground

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 363
  • Karma: 10
    • View Profile
Re: NHD-0216K1Z-NSW-BBW6L contrast problem
« Reply #3 on: December 12, 2017, 01:16:12 PM »
Can you give me more information about where the display is used?

I can see what you mean by the browning on the display, this leads me to believe that something is causing extreme heat build up on or near the display.
The low contrast stripes lead me to believe this might be a connection issue with the Zebra strips and the PCB.

Do you know if there is any dust entering the display or any liquids used near by? Another issue could be that the com/seg traces could be getting shorted and destroyed.

bidbid21

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0216K1Z-NSW-BBW6L contrast problem
« Reply #4 on: Today at 02:56:25 AM »
The display is assembly on electronic card that is RFID Reader. This reader is powered by ethernet PoE. The supply of display is regulared by LD50 regulator + capacitor and zener diode (for protect)
The stikers on lcd display has browned because I think the chip on display heated.
I have measure the temperature of display after 1hour of use in real condition. I have got 38°celsius in touch display chip.
For tests, I have disassembly display (chip and LCD Cell) and i have reverse old LCD cell to new PCB and new LCD cell to old PCB
old LCD cell on new PCB (i noticed dead pixels
new LCD cell on old PCB

 

NHD‐3.5‐320240MF‐ATXL#‐CTP‐1 Problem with standby mode

Started by guenterBoard TFTs

Replies: 0
Views: 2010
Last post June 16, 2016, 12:14:36 PM
by guenter
NHD‐2.4‐240320SF‐CTXL#‐FTN1 touch-screen problem

Started by hbcelebiBoard TFTs

Replies: 5
Views: 4305
Last post December 10, 2014, 11:19:05 AM
by Michael_L
Working on NHD‐2.4‐240320SF‐CTXL#‐FTN1, have problem in initialization

Started by sli25Board TFTs

Replies: 6
Views: 3918
Last post June 04, 2015, 09:52:25 PM
by sli25
Problem in bringing up NHD‐2.4‐240320SF‐CTXL#‐FTN1 on Renesas RL78/G14

Started by sli25Board TFTs

Replies: 3
Views: 3171
Last post May 28, 2015, 02:59:03 PM
by Michael_L
problem with NHD‐2.23‐12832UCB3

Started by luisvalsecaBoard OLEDs

Replies: 1
Views: 960
Last post January 24, 2017, 02:52:53 PM
by Saurabh_B