Author Topic: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off  (Read 2226 times)

PHITEK

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« on: January 10, 2016, 02:25:44 PM »
I am having a problem with the Turn off display command when I use RS-232 communication mode. I have some test code in C# running on .NETMF platforms from www.GHIElectronics.com.

Initially I had hoped to use SPI communications mode with worked fine on one platform. Two of there other platforms I could not slow the SPI Clock down low enough, so I decided to use the RS-232 communications mode.  I am using the default 9600 baud rate.

My test program ran for many hours using the SPI communications mode.

What happens on the first use of the Display OFF command, is the characters on the display disappear but then nothing else seems to turn the display back on. I have to remove the power and re-power up the display.

Is this a known issue?

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 340
  • Karma: 10
    • View Profile
Re: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« Reply #1 on: January 11, 2016, 10:04:42 AM »
I have not heard of this issue.

Can you confirm the rest of the RS-232 settings?
- 1stop bit
- no parity
- no hand-shaking

Also would it be possible to share the list of commands you are sending to the display?

PHITEK

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« Reply #2 on: January 11, 2016, 05:04:34 PM »
Yes the baud rate, parity, data bits, and handshaking all match.

I have a test program that does quite a bit of the functionality, and is based on this sample.
https://www.ghielectronics.com/community/codeshare/entry/166

I have adjusted the timing (increased the delays), especially have the Clear command, I had to fix a number of issues, mainly how backspace is handled. Got this code running on the SPI interface fine, switching to RS-232 was mainly adding more delay to the clear command and the crash with Turn Display Off, commenting out this command it runs fine overnight.

I will see if I can get a smaller program to exhibit the display crash, and post back here in a few days.

Thanks for your attention to this matter.

PHITEK

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« Reply #3 on: January 14, 2016, 05:42:55 AM »
I found my issue, I have change the Display On method to sending a single byte for testing the I2C interface with a scope and never changed it back to 0xFE, 0x41. So once I turned the display off there was not way to turn it on again.

Thanks for you help on this matter

Regards,
Phil

Paul_B

  • Administrator
  • Sr. Member
  • *****
  • Posts: 248
  • Karma: 16
    • View Profile
Re: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« Reply #4 on: January 14, 2016, 08:15:37 AM »
Morning Phil,

Glad to hear you're up and running! Thank you for sharing your solution so anyone else having similar problems can solve them  ;)

BobDyer

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: NHD-0220D3Z-NSW-BBW-V3 - RS-232 mode and Turn display off
« Reply #5 on: January 21, 2016, 10:28:30 AM »
I was also in the same trouble some days ago.
So can you confirm the rest of the RS-232 settings?
1stop bit
no parity
no hand-shaking
Also would it be possible to share the list of commands you are sending to the display?

circuit board fabrication
« Last Edit: January 28, 2016, 03:39:30 PM by BobDyer »

 

Blank Display on NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM

Started by SteveCBoard Character LCDs

Replies: 3
Views: 4368
Last post May 13, 2014, 12:04:36 AM
by SteveC
NHD‐C12864A1Z‐FSW‐FBW‐HTT display clears after draw

Started by EdAverillBoard Graphic LCDs

Replies: 6
Views: 5425
Last post November 07, 2014, 08:25:20 AM
by Michael_L
NHD‐4.3‐480272EF‐ATXL#‐CTP | FAN5333 | BBB | Nothing on the Display

Started by Alias_AliasBoard TFTs

Replies: 1
Views: 3203
Last post September 25, 2015, 03:09:24 PM
by Paul_B
Arduino LCD library not working with newhaven display NHD‐0420H1Z‐FL‐GWB-3V3

Started by c2hollowBoard Character LCDs

Replies: 9
Views: 8261
Last post July 10, 2014, 08:46:06 AM
by Michael_L
NHD-0420DZW-AG5 - Display "sometimes" shows only 2 lines

Started by stylonurusBoard OLEDs

Replies: 5
Views: 5393
Last post June 18, 2014, 10:09:49 AM
by Michael_L