Author Topic: Character LCD NHD‐0220D3Z‐NSW‐BBW‐V3 not receiving correct characters  (Read 3702 times)

davek

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
I am having difficulty using the LCD described herein.
When sending hex characters to the LCD I am not getting what is expected. 

I'm using a Serial LCD (NHD‐0220D3Z‐NSW‐BBW‐V3 revision 15) and sending data to it via Terminal Emulator (TERMITE) in 8N1 9600 Baud.
I have tried direct communication using both the RS232 side of transceiver and the TTL side of RS232 Transceiver.
Transceiver is successfully performing with other projects.

I'm running off a Bench top PS at 5V.

I am only wired to Pins 1, 2, & 3 (Rx, Gnd, VCC) of the LCD.
When I attempt to connect Host TX to LCD TX on the TTL side of RS232 Transceiver the LCD doesn't power up.
When I connect the Host TX to LCD TX on the RS232 side of Transceiver, the LCD lights up but when I send characters to the LCD from the host, I characters not intended.

When I send "0x9f" I get "0" on LCD
When I send "0x9d" I get "1" on LCD
...
The datasheet states it's built in Font Table should display a "y" when I issue a "0x9F" but instead it displays a "0"

AND OF COURSE, I can not get the LCD to respond to other commands like POWER ON, POWER OFF, etc.
Sorry, my setup is not conducive for taking pictures and posting.

Any ideas what I might be doing wrong?

Dave
 

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 379
  • Karma: 10
    • View Profile
Hi Davek,

I have a few more questions, while you are providing 5V to the power, is your logic voltage also 5V?
Can you confirm that you have:
8-Bit Data,
1 Stop Bit,
No Parity Bits,
No Handshaking.

0x9F would leave you somewhere int he center of the table which isn't defined. For y you should be sending 0x79 for the larger y you should send 0xF9


 

NHD-2.7-12864UCY3 yellow columns occur under ascii characters

Started by bsoyerBoard OLEDs

Replies: 7
Views: 6006
Last post August 26, 2015, 11:02:25 AM
by tracyb
NHD-C0220BiZ-FSW-FBW-3V3M NAKs all odd numberd ASCII characters

Started by majorninthBoard Character LCDs

Replies: 7
Views: 5641
Last post May 28, 2015, 04:51:31 PM
by Michael_L
NHD-0420E2Z-NSW-BBW is displaying Japanese Characters instead of my string

Started by shaneyostBoard Character LCDs

Replies: 1
Views: 6311
Last post June 03, 2014, 10:11:25 AM
by Michael_L
NHD-0420D3Z-NSW-BBW-V3 i2c display and Arduino missing characters

Started by 0miker0Board Character LCDs

Replies: 0
Views: 2812
Last post July 06, 2017, 11:05:59 AM
by 0miker0
Problem with NHD-0420CW-AR3 - Double spaced characters now.

Started by JKleiberBoard OLEDs

Replies: 0
Views: 280
Last post May 05, 2018, 07:32:51 PM
by JKleiber