Author Topic: Blank display after several hours of working normally  (Read 1231 times)

darrow

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Blank display after several hours of working normally
« on: October 25, 2016, 08:01:02 AM »
Hello,

We are using the New Haven NHD-2.4-240320CF-CSXN#-F in one of our products and we are having a sporadic issue:

Every now and then, after running for a few hours, the display goes completely white and won't draw anything (it seems like it somehow gets de-initialized). Only a hard reset seems to correct the problem. The MCU on our board is fine and still running properly. The product still responds to commands, buttons can be pressed etc... everything else works perfectly normal except that the display is white and never changes.

Any idea what could be causing this? Sometimes the product can run for 24hrs or more without issue, so the time between power-up and display failure is not consistent.

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: Blank display after several hours of working normally
« Reply #1 on: October 25, 2016, 08:50:16 AM »
Hello,

It sounds like the display is getting reset.
Do you know if the Reset Pin on your display is tied high constantly?

darrow

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Blank display after several hours of working normally
« Reply #2 on: October 25, 2016, 11:01:03 AM »
The Reset Pin on the display is not tied high constantly, it is connected to a pin on our microcontroller and that microcontroller pin is set to output high once during bootup and then never changed again.

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: Blank display after several hours of working normally
« Reply #3 on: October 25, 2016, 11:49:48 AM »
Do you know if the voltage applied to the display pins 7&8 is constant the whole time.
Another cause could be a reset caused by either a loose connection or just power dropping.

Finally do you know if yoru code might be sending the Display OFF command or the Sleep Command?

darrow

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Blank display after several hours of working normally
« Reply #4 on: October 25, 2016, 02:47:01 PM »
I will have to test to see if pins 7&8 are getting voltage, I have not checked that yet. I am almost certain that it is not a loose connection because our bench test fixture never moves, but I suppose power dropping could be possible.

As far as Display OFF and Sleep, we only send any commands like that during initialization on boot.

We have since discovered that with whatever is happening with the display, we can still fill the frame memory, so the controller is still working (or at least communicating). We discovered this by waiting for the display to go blank, sending commands to fill the frame memory with an image, and then running a modified version of the initialization routine that doesn't clear the frame memory. Sure enough when we did this, we see the image that we sent while it was blank.

It looks like are some status registers on the ST7789S that we can read that might tell us more. Would you recommend doing this?

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: Blank display after several hours of working normally
« Reply #5 on: October 25, 2016, 03:34:24 PM »
This does sound like something is causing the display to reset externally.

You should be able to fill the frame buffer at any time. After the display re-initializes and you send the display ON command, it will show whatever is filled in the buffer.

darrow

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
Re: Blank display after several hours of working normally
« Reply #6 on: October 27, 2016, 07:01:40 AM »
Does an external reset cause the frame memory to be cleared?

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: Blank display after several hours of working normally
« Reply #7 on: October 27, 2016, 01:54:07 PM »
An external reset would clear the contents of the display.

However if the display is retaining the image in the RAM, it sounds like the power to the display might be dropping momentarily before the RAM losses the stored data.

 

NHD‐C12864A1Z‐FSW‐FBW‐HTT display clears after draw

Started by EdAverillBoard Graphic LCDs

Replies: 6
Views: 5709
Last post November 07, 2014, 08:25:20 AM
by Michael_L
NHD‐4.3‐480272EF‐ATXL#‐CTP | FAN5333 | BBB | Nothing on the Display

Started by Alias_AliasBoard TFTs

Replies: 1
Views: 3420
Last post September 25, 2015, 03:09:24 PM
by Paul_B
NHD-0420DZW-AG5 - Display "sometimes" shows only 2 lines

Started by stylonurusBoard OLEDs

Replies: 5
Views: 5582
Last post June 18, 2014, 10:09:49 AM
by Michael_L
NHD-C0220BiZ Sometimes Ignoring "Clear Display" Command

Started by dstoverBoard Character LCDs

Replies: 2
Views: 3756
Last post March 27, 2014, 05:41:27 PM
by Michael_L
Optical bonding Display to cover glass (dry film bonding)

Started by fourtraxBoard TFTs

Replies: 1
Views: 1109
Last post September 29, 2016, 08:35:00 AM
by Saurabh_B