Author Topic: I2C Errors on NHD-0216CW-AB3 but not NHD-0220CW-AB3  (Read 1028 times)

Eric

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
I2C Errors on NHD-0216CW-AB3 but not NHD-0220CW-AB3
« on: December 01, 2016, 11:09:50 AM »
We recently designed a circuit around your 16x2 OLED display (p/n NHD-0216CW-AB3).  Prior to this, we were using your 20x2 display (p/n NHD-0220CW-AB3).  The display is being controlled using the I2C interface from NXP micro LPC1837.  The bus is running at 400KHz and have no problems with the 20x2 display.  After switching to the 16x2 display, occasional I2C bus errors are observed (including NACK and erroneous display characters).  Both display and micro are being powered by 3.3V (VDD = 3.3V, REGVDD = GND).

The data sheet timing between the two devices are identical, so we're quite puzzled.  Has anyone experienced similar issues?




Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 250
  • Karma: 16
    • View Profile
Re: I2C Errors on NHD-0216CW-AB3 but not NHD-0220CW-AB3
« Reply #1 on: December 02, 2016, 08:38:39 AM »
Morning Eric,

I’m sorry to hear about the trouble you are having with the NHD-0216CW-AB3. All displays are tested before they leave our facility. We have never experienced this issue, both displays utilize the US2066 controller and share the same timing.

Can you provide me with a detailed pin-out diagram so I can verify your connections / pull-ups?


JDW

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: I2C Errors on NHD-0216CW-AB3 but not NHD-0220CW-AB3
« Reply #2 on: December 06, 2016, 09:22:12 AM »
Hi we have the I2C same problems on NHD-0216CW-YA3, powered by 5V, running on 100Khz, 4K7 pull-up resistors. The I2C bus errors are, NACK, wrong characters are displayed,  display holds the clock low to terminated the communication cycle.

Michael_L

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 33
    • View Profile
Re: I2C Errors on NHD-0216CW-AB3 but not NHD-0220CW-AB3
« Reply #3 on: December 08, 2016, 02:30:08 PM »
There is a known issue on our Slim Character OLED display modules which affects its operation when used in I2C mode.
When using the module’s I2C interface, AND using 5.0V operation, I2C bus errors such as NACKs/bit errors/hanging, may occur.

The I2C interface, when low voltage operation (2.4-3.6V) is used, works correctly without any such errors.
The display’s Parallel interface options, along with the SPI interface option, are not affected by this issue, and may be used as the original specification indicates.

Therefore, if using the I2C interface of these Slim Character OLED display modules, 5.0V operation should NOT be used.
If only 5.0V logic is available, and I2C must be used, as a work-around you may use 5.0V I2C, as long as 2.4-3.6V is available for VDD.

In either case (3.3V or 5V I2C logic), if the I2C interface must be used, the following must be true for reliable operation:
-   2.4-3.6V applied to VDD (pin 2)
-   0V/GND applied to REGVDD (pin 3)
-   During initialization, you must send the “Function Selection A” command (available after setting the ‘RE’ bit to ‘1’ in the “Function Set” command), with the following parameter for A[7:0] being 0x00.  This disables the internal VDD regulator.
For additional details, please refer the Table of Commands beginning on page 7 of the Slim Character OLED display module’s datasheet.

We have updated the I2C section of our datasheet to reflect this information, and the updated specs should be accessible on our website shortly.
If you have any questions or need any assistance getting these OLED modules working, please contact us by emailing our technical support email nhtech@newhavendisplay.com, or by calling our phone M-F, 8am - 5pm CST (number listed on our website in the contact us section), we're always happy to help!  :D
« Last Edit: December 20, 2016, 07:43:41 AM by Michael_L »

 

NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue

Started by forteyBoard OLEDs

Replies: 14
Views: 7702
Last post March 09, 2015, 02:23:51 PM
by Retheesh_M
Safe to run NHD-0216CW-AB3 displays at 3.3V long-term?

Started by bluemountainBoard OLEDs

Replies: 2
Views: 2217
Last post January 14, 2015, 12:19:16 PM
by bluemountain
NHD-0220CW-AB3 "doubling" data?

Started by GerryOBoard OLEDs

Replies: 2
Views: 2020
Last post October 25, 2015, 03:25:07 AM
by GerryO
NHD-0216CW-AB3 dots underneath characters

Started by cprobertBoard OLEDs

Replies: 0
Views: 1584
Last post November 19, 2015, 10:26:39 AM
by cprobert
NHD-0216CW-AB3 displaying wrong chracters

Started by The Fat BastidBoard OLEDs

Replies: 0
Views: 658
Last post April 13, 2017, 11:41:11 PM
by The Fat Bastid