Author Topic: NHD-0420DZW-AB5 Excessive Supply Current  (Read 2729 times)

peterrash

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
NHD-0420DZW-AB5 Excessive Supply Current
« on: May 02, 2014, 12:20:22 PM »
I've just purchased a 4x20 OLED Character display, but when I first powered up my circuit, the text on the display was flickering and dim. Investigation revealed that my 5V regulator was exceeding its maximum current limit of 200mA and was therefore only operating at around 2.5V (with severe ripple).

With an external 5V supply capable of over 30A connected directly to the display, the brightness is normal, although there still seems to be some flickering. I placed a multimeter in series with the 5V supply pin of the display, and measured about 240mA with all 4 rows displaying text, and about 150mA with the display uninitialized (MCU power off). I believe that this explains my earlier regulator failure, however the display datasheet indicates that the current should be 60mA. Has anyone seen behavior like this, and if so, can you give me troubleshooting suggestions? I've got an email in to Newhaven Tech Support, but I need to get this working ASAP.

I am trying to determine if this is indicative of a defective display, or a problem with the circuit that is driving it. Unfortunately, I don't have a spare display to try swapping with this one.

The display is connected according to the datasheet schematic using the 4-bit parallel interface. I am driving it with an Atmel ATmega328P at 5V.

Thanks in advance for any suggestions.

-Peter

peterrash

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: NHD-0420DZW-AB5 Excessive Supply Current
« Reply #1 on: May 03, 2014, 11:45:56 AM »
UPDATE:

I have discovered that one of the ICs on the display, U3, is getting extremely hot almost immediately on power-up. I guess I got a defective display.

Michael_L

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 33
    • View Profile
Re: NHD-0420DZW-AB5 Excessive Supply Current
« Reply #2 on: May 06, 2014, 12:10:50 PM »
You should have received an email from our engineering department regarding this, in response to the email you sent to nhtech@newhavendisplay.com.
If there are further questions you may reply back to the email you received.

 

Questions regarding NHD‐0220DZW‐AY5 & NHD‐0420DZW‐AY5

Started by tseyfarthBoard OLEDs

Replies: 3
Views: 2730
Last post August 20, 2015, 09:51:26 AM
by Saurabh_B
NHD‐0420DZW‐AB5 Lines

Started by RickJBoard OLEDs

Replies: 1
Views: 2177
Last post January 09, 2015, 04:18:32 PM
by Michael_L
NHD‐0420DZW‐AY5 SPI Interface

Started by vinaykBoard OLEDs

Replies: 0
Views: 1952
Last post October 26, 2015, 05:13:10 AM
by vinayk
NHD-0420DZW-AG5 - Display "sometimes" shows only 2 lines

Started by stylonurusBoard OLEDs

Replies: 5
Views: 5421
Last post June 18, 2014, 10:09:49 AM
by Michael_L
NHD‐0420DZW‐AY5 - Power consumption and luminance difference 3.3V/5.0V?

Started by MonkeywrenchBoard OLEDs

Replies: 0
Views: 1404
Last post November 20, 2015, 06:40:16 PM
by Monkeywrench