Newhaven Products > Character LCDs

Blank Display on NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM



I've built 3 prototypes using the NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM LCDs and all 3 stay blank all the time. Here are the voltages on the pins... all 3 read almost identically:
Pin #1 - /RESET - 3.30V
Pin #2 - SCL - 3.63V
Pin #3 - SDA - 3.63V
Pin #4 - Vss - 0.00V
Pin #5 - VDD - 3.30V
Pin #6 - VOUT - 2.97V
Pin #7 - C+ - 3.28V
Pin #8 - C- - 0.02V

I'm a bit concerned with Pin#6 as it seems the voltage converter isn't working. I'm using 1uF, 25V MLCCs across pin #7 and #8. Plus another from pin #6 to pin #4. Reset is pulled up to 3.3V with a 10K resistor. The microcontroller has weak pullups to +5V which is why SCL and SDA are a bit higher than 3.3V.

I've tried using the evaluation software and 2 different microcontroller eval boards but nothing seems to help. The LCDs are always completely blank.

I've tried changing the Slave Address to 0x7C but no change.

I should also add that I've looked at the I2C signals on a scope and they look OK. SCL is running at 100KHz and the software example just keeps running in the loop.

Any help would be most appreciated. I must be missing something very basic.... arggg.....

Is there any possibility the pinouts for Vdd and Vss are switched? Perhaps Pin #4 is Vdd (+3.3V) and Pin #5 is Vss (0.0v)? Or should this display run at Vdd = 5V?

Thank you.

Since you're getting those voltages on pin 6 and 7, it seems that you have not successfully communicated with the display and issued the proper commands to turn on the booster circuit.  Also, the voltages on SCL and SDA are higher than the specification max limit for input high voltage (VDD).  At first guess, I would say this is the reason you are unable to communicate with the display.  Suggested pull-ups for SCL and SDA are 10kΩ on each line tied to 3.3V.  Also, what slave address are you using?  It should be 0x78 (or 0x3C shifted over one bit, for when you are using certain built-in I2C software modules such as the Arduino platform).

VDD and VSS are not switched, they are in the correct order as indicated in the spec.  The display runs on 3.3V, not 5V.

Lastly, have you referenced the code for this display I have posted here?:,19.0.html

Thank you for your reply! I will run some tests tomorrow and post my results.

Hello Michael, Thank you for your suggestion. Changing the I2C address to 0x3C worked! I can see text on the LCD now. I'm sure we can make some progress now.


[0] Message Index

Go to full version