Author Topic: NHD-5.0-800480TF-ATXL# Display timing  (Read 915 times)

l_pochhi

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
NHD-5.0-800480TF-ATXL# Display timing
« on: April 27, 2017, 05:09:36 AM »
We are using NHD-5.0-800480TF-ATXL#  for our product.
Our hardware interface is as follows:
1. We are using LVDS port from Linux Board (Gatewoeks GW5400 with Ubantu). It has TX0, TX1, TX2 and CLK balanced lines.
2. We are using DS90C364 for converting LVDS to RGB connection of the Display.
3. R0,R1, G0,G1, B0,B1 are at logic zero, because it provides 666 output.
 
We have made the timing settings as per your datasheet.
 
clock-frequency = <40000000>;
hactive = <800>;
vactive = <480>;
hback-porch = <88>;
hfront-porch = <40>;
vback-porch = <32>;
vfront-porch = <13>;
hsync-len = <48>;   /// Tested with 1 , 10 and 24 also
vsync-len = <3>;

But we are not getting the proper display.

Please suggest proper timing parameters

Best regards

The Display is attached herewith

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: NHD-5.0-800480TF-ATXL# Display timing
« Reply #1 on: April 28, 2017, 04:56:35 PM »
Hello,

Can you tell me what the date code on the display is, or if you could please provide a picture of the back of the display?

l_pochhi

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-5.0-800480TF-ATXL# Display timing
« Reply #2 on: April 29, 2017, 02:53:56 AM »
Dear saurabh

please see back side view.

Best regards

kroysoft

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: NHD-5.0-800480TF-ATXL# Display timing
« Reply #3 on: July 05, 2017, 08:06:41 AM »
Hello,

I'm Charles. I bought the same type of display a few days ago, and I'm facing almost the same problem here. There are only three small differences with my display, however:

1. I'm using almost the same timing as above, except the clock which is set to 35.88MHz to achieve 75Hz refresh rate. (I tried with other clocks, by the way, but with the same result as below)
2. the "shifting" of the visible area in my case is not to right with (how many pixel, I can't see on the attached picture :) ) but left and only 4 with pixels. Playing around with 'HS front porch' I do can change the shifting itself in any direction, but in steps of 8 pixels, so I simply can't set the proper position!
3. I'm using a HDMI-TTL converter IC from texas: the TFP401a for signal conversion.
+1 I'm using DTDCalculator to do the "timing magic" under Windows 10 on a compute stick with HDMI output.

My display got these number on it's back (hope it helps): 500444_3216 NHD-5.0-800480TF-ATXL#-T_rev14

Thanks for any advice!

 

Blank Display on NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM

Started by SteveCBoard Character LCDs

Replies: 8
Views: 4600
Last post November 24, 2017, 09:22:35 PM
by tolikkk
NHD‐C12864A1Z‐FSW‐FBW‐HTT display clears after draw

Started by EdAverillBoard Graphic LCDs

Replies: 12
Views: 5756
Last post November 24, 2017, 11:47:00 PM
by tolikkk
Arduino LCD library not working with newhaven display NHD‐0420H1Z‐FL‐GWB-3V3

Started by c2hollowBoard Character LCDs

Replies: 19
Views: 8915
Last post November 24, 2017, 06:49:46 PM
by tolikkk
NHD-0420DZW-AG5 - Display "sometimes" shows only 2 lines

Started by stylonurusBoard OLEDs

Replies: 5
Views: 5608
Last post June 18, 2014, 10:09:49 AM
by Michael_L
NHD-C0220BiZ Sometimes Ignoring "Clear Display" Command

Started by dstoverBoard Character LCDs

Replies: 2
Views: 3774
Last post March 27, 2014, 05:41:27 PM
by Michael_L