Author Topic: OLED Update timing problem  (Read 227 times)

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
OLED Update timing problem
« on: October 24, 2017, 05:03:43 AM »
Hi,

         i am working with LCD with updating data to LCD in 250 mS Interval is working fine.

but updating data to OLED is not working it will print only junk characters.

Kindly provide solution for the above same.

Thanks in advance.

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #1 on: October 24, 2017, 05:08:27 AM »
And also i have one doubt,

when power OFF and ON the display work properly.

for every reset it will print junk characters.

IS THERE ANY COMMAND NEEDED TO GIVEN AFTER RESET OR HAVE TO CONNECT ANY CONNECTION BETWEEN CONTROLLER AND OLED

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #2 on: October 24, 2017, 05:28:25 AM »
Hi,

            by pressing reset button periodically in my controller it will print junk values how can i eliminate the problem.

kindly provide the solution for the above said 3 problems.

thanks in advance.

regards,
nathan babu

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: OLED Update timing problem
« Reply #3 on: October 24, 2017, 08:02:57 AM »
What OLED are you using?
Depending on the controller used the timing will be different.

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #4 on: October 24, 2017, 08:07:36 AM »
hi sir,

 thanks for your reply.

I am using NHD - 0420DZW - AB5 OLED and my controller is 32 bit micro controller.

when power OFF and ON Sequence is performed it is working fine.

when reset button is pressed in the controller the data in the OLED gets displayed as junk value.

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: OLED Update timing problem
« Reply #5 on: October 24, 2017, 08:26:49 AM »
You are probably sending information to the display quite fast for this to happen.
Is it possible for you to insert a delay between each character you write to the display. Also inserting a delay between any commands sent.

Typically i recommend a 600Ás delay between most commands / data writes.
You will need about a 2ms display after sending a clear display or return home command.

After the reset is applied are you reinitializing the display?


nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #6 on: October 24, 2017, 10:24:30 PM »
Yes i reinitializing it.

but after power ON it is working.

during reset only junk values presents.

i may think that during power off and on OLED Supply voltage is disconnected and connected and during reset no supply interruption. is that may provide junk characters.

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: OLED Update timing problem
« Reply #7 on: October 25, 2017, 04:01:24 PM »
When you reset the MCU do you know if it sends any random information out of the port that's connected to the LCD?

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #8 on: October 25, 2017, 09:59:18 PM »
No Data send to OLED. we checked across data and control lines of OLED using CRO.

But it prints junk values always again power ON / OFF required to solve this scenario.

After power OFF and ON Immediately it will work.

Same scenario as reset key press and release or power ON/ OFF

Kindly guide me how to resolve this

We have one more problem that working good in LCD but in OLED Display will be blank (no data) in the display after some period of time but data received to OLED we checked with voltage level and using CRO also.

time of the data blanking can be changed periodically 1 Minute, 5 Minute or 10 Minute interval.
« Last Edit: October 26, 2017, 07:10:16 AM by nathanbabu »

nathanbabu

  • Jr. Member
  • **
  • Posts: 16
  • Karma: 0
    • View Profile
Re: OLED Update timing problem
« Reply #9 on: October 26, 2017, 01:04:17 PM »
Kindly provide some solution for the below same

No Data send to OLED. we checked across data and control lines of OLED using CRO.

But it prints junk values always again power ON / OFF required to solve this scenario.

After power OFF and ON Immediately it will work.

Same scenario as reset key press and release or power ON/ OFF

Kindly guide me how to resolve this

We have one more problem that working good in LCD but in OLED Display will be blank (no data) in the display after some period of time but data received to OLED we checked with voltage level and using CRO also.

time of the data blanking can be changed periodically 1 Minute, 5 Minute or 10 Minute interval.

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 10
    • View Profile
Re: OLED Update timing problem
« Reply #10 on: October 26, 2017, 04:05:03 PM »
I am still unsure how you are getting characters to show up when the display is powered on.
All of our OLED displays do not show any information until they have been given data to show.

Would it be possible to show me a picture of what characters you are seeing, also a video describing the problem.

I believe the DDRAM of the OLED display is being updated when the power is not appled.

One simple solution is to use the display OFF command after the display boots up from a reset / power off. After this i would recommend doing a clear display before using the display ON command.

 

NHD‐3.5‐320240MF‐ATXL#‐CTP‐1 Problem with standby mode

Started by guenterBoard TFTs

Replies: 0
Views: 1949
Last post June 16, 2016, 12:14:36 PM
by guenter
NHD‐2.4‐240320SF‐CTXL#‐FTN1 touch-screen problem

Started by hbcelebiBoard TFTs

Replies: 6
Views: 4191
Last post Today at 02:47:05 AM
by tolikkk
Working on NHD‐2.4‐240320SF‐CTXL#‐FTN1, have problem in initialization

Started by sli25Board TFTs

Replies: 6
Views: 3804
Last post June 04, 2015, 09:52:25 PM
by sli25
Problem in bringing up NHD‐2.4‐240320SF‐CTXL#‐FTN1 on Renesas RL78/G14

Started by sli25Board TFTs

Replies: 3
Views: 3072
Last post May 28, 2015, 02:59:03 PM
by Michael_L
problem with NHD‐2.23‐12832UCB3

Started by luisvalsecaBoard OLEDs

Replies: 1
Views: 901
Last post January 24, 2017, 02:52:53 PM
by Saurabh_B