Author Topic: NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem  (Read 108 times)

Chruetli

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem
« on: December 01, 2017, 02:40:04 PM »
I'm using an embedded Linux system - with a dedicated I2C bus - to drive a "NHD-C0220Biz-FS(RGB)-FBW-3VM" display. The Linux kernel module supplies an I2C master, so I do not have to bit bang.
Using 'i2c_master_send(...)' does the addressing, clocking and so on. Most calls work but 0x39 and 0x01 don't work...
0x0  -> ok
0x38 -> ok
0x39 -> fail
0x14 -> ok
...
0x0c -> ok
0x01 -> fail
...


I also tried to make 2 byte packets {0x0, 0x?} and send them together but the same commands failed. And there is no visible reaction on the display.
Any sugestins?
« Last Edit: December 01, 2017, 03:29:41 PM by Chruetli »

Chruetli

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem
« Reply #1 on: December 03, 2017, 02:59:51 AM »
Hmm, just found out that my dev board has 2.2k pull-up on SCL and SDA lines - instead of 10k as recommended. But my logic analyzer show all commands as expected...

Saurabh_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 363
  • Karma: 10
    • View Profile
Re: NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem
« Reply #2 on: December 05, 2017, 08:15:02 AM »
Are you sending a delay between the commands or allowing the commands that were sent to execute?

Chruetli

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem
« Reply #3 on: December 07, 2017, 07:18:41 PM »
Solved, the 2.2k poll-up was the root of the evil. Removed from the demo board and replaced by an external 10k, all is doing right!! Those 10k are pretty important...

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 251
  • Karma: 16
    • View Profile
Re: NHD-C0220Biz-FS(RGB)-FBW-3VM initialization problem
« Reply #4 on: December 08, 2017, 07:52:14 AM »
Glad to hear you got your display up and running!

Thanks for sharing your solution, it will definitely help others  :D

 

NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM capacitor on pin 7&8

Started by Ticoti0xFFBoard Character LCDs

Replies: 1
Views: 2871
Last post April 09, 2014, 10:17:30 AM
by Michael_L
NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM Potting

Started by SebKisterBoard Character LCDs

Replies: 1
Views: 1886
Last post June 22, 2016, 04:51:17 PM
by Saurabh_B
NHD‐3.5‐320240MF‐ATXL#‐CTP‐1 Problem with standby mode

Started by guenterBoard TFTs

Replies: 0
Views: 2019
Last post June 16, 2016, 12:14:36 PM
by guenter
NHD‐2.4‐240320SF‐CTXL#‐FTN1 touch-screen problem

Started by hbcelebiBoard TFTs

Replies: 5
Views: 4321
Last post December 10, 2014, 11:19:05 AM
by Michael_L
Problem in bringing up NHD‐2.4‐240320SF‐CTXL#‐FTN1 on Renesas RL78/G14

Started by sli25Board TFTs

Replies: 3
Views: 3178
Last post May 28, 2015, 02:59:03 PM
by Michael_L