Author Topic: NHD-7.0CTP-CAPE - BBB does not start up properly  (Read 5202 times)

hendrik

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
NHD-7.0CTP-CAPE - BBB does not start up properly
« on: February 05, 2018, 05:20:44 AM »
Hello,
I have trouble with NHD-7.0CTP-CAPEs. I am using them with a beagleboneblack wireless. When I plug in the 5V power supply (3A) to the bbb while it is connected to the display, the display and the bbb power LED start to blink, but the beaglebone won't boot. The problem occurs with any software I tried so far. I have one beaglebone with android 4.2 installed which starts sometimes after some blinks, but this happens randomly and by far not every time I plug it in. Any suggestions why the displays do not work properly?

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #1 on: February 05, 2018, 07:55:32 AM »
Morning,

Iím sorry to hear about the trouble you are having with the NHD-7.0CTP-CAPE.

It would be helpful to see your boot process. To see the actual boot process a RS232 cable like the TTL-232R-3V3 from FTDI is needed. Just plug it into the J1 connector (located on the BBB) and open a serial terminal of your choice.

Lastly, can you confirm that everything is operational with your beagleboneblack wireless? You wouldn't happen to have a second one available for testing?

Regards,

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #2 on: February 05, 2018, 08:02:25 AM »
I know this might sound odd but can you please tell me what brand microSD card you are utilizing?

It sounds like an obvious thing to avoid, but sadly, is there any chance you purchased a fake/bad microSD card?




hendrik

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #3 on: February 06, 2018, 03:58:02 AM »
There is no output during boot process when the cape is attached, since it just shuts down immediately. I tested it with 2 bbbwl on 2 capes. SD cards are xlyne microSD HC class 10 and a sandisk ultra hc class 10, both 16gb, but usually not in use, because I boot from mmc. To me it looks like some start-up overcurrent issue with a shutdown caused by OSD3358 power management chip.
I tried disconnecting the SYS_5V on startup and attached it after boot process. With this configuration the bbb boots properly and the display can be used, but this is obviously way too uncomfortable.

Additionally I tried it with a BBB (non wireless) and everything works fine out of the box.

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #4 on: February 06, 2018, 09:57:42 AM »
Thank you for the information, can you please let me know which NHD-7.0CTP-CAPE you purchased i.e. L, N, or V?

Are you using the Images available for download in the User Guide or spinning your own overlay?

The NHD-7.0CTP-CAPE was originally designed for the BeagleBone Black (non wireless) back in 2016. I'll try to get my hands on the BBB (wireless) early next week and see if I can replicate the issue you are experiencing.

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #5 on: February 14, 2018, 03:27:08 PM »
Afternoon Hendrik,

I've completed testing on the NHD-7.0CTP-CAPE utilizing the new BeagleBone Black Wireless and managed to replicate the issue you are experiencing. The issue seems to stem from the OSD3358 power management chip exclusively on the new BeagleBone Black Wireless model.

If you are having this issue, please see the work-around below:

Disclaimer:Modified product will void warranty.

  • Cut pins 7 & 8 on connector P1_B
  • Solder a 0 Ohm resistor (or solder bridge) between pins 5 & 7

This enables the backlight circuit to run off VDD_5V (main power supply from the DC input jack) instead of SYS_5V (main rail for the regulators on the main board).

newto

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #6 on: February 27, 2018, 11:47:01 AM »
Hello Hendrik and/or Paul_B

Lucky timing that this question popped up recently, as I have a related one.

Do the wireless functions (wifi and bluetooth) still work with the 24-bit cape installed (and the modifications listed complete)? I've seen a few places that some of the extra pins required for 24 bit over 16 bit colour are also used for wireless addons for earlier beaglebone boards, and I wanted to make sure those features still work with the integrated wireless chip.

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #7 on: March 02, 2018, 11:15:04 AM »
Hi Newto,

I believe the WiFi/Bluetooth pins were taken from the 10/100 Ethernet pins (don't quote me on that)...

The BeagleBone Black Wireless is still fairly new to me, I'll have to do some additional testing to confirm  ;)


jerryp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #8 on: September 19, 2019, 12:45:58 PM »
I too am having no luck getting the NHD-7.0CTP-CAPE -L to work with my Beaglebone Black Wireless. I tried the modified power configuration that you described in an earlier thread - removing pins 7 and 8 (P1_B) from the circuit then shorting 7 to 5. No success. I get a boot and a heartbeat. But, no cape display function.
This particular BBB-WL works with other capes including HDMI type. So, I can confirm that it is functional I also have 5 more BBB-WL and 5 more NHD-7.0CTP-CAPE-L units to work with. Same unsuccessful results.

I have another project where I use this exact cape with a regular BBB and it seems to be fine.
Is this just a compatibility issue that cannot be resolved, or is there hope?

-Jerry

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #9 on: September 19, 2019, 02:10:12 PM »
Hi Jerry,

Iím sorry to hear about the trouble you are having with the NHD-7.0CTP-CAPE, it appears to be a software issue.

The following thread should provide a solution:
https://github.com/beagleboard/bb.org-overlays/issues/76

Unfortunately, I don't have the BBBW (wireless) in the lab at this time... I'll try and get my hands on another one early next week so I can confirm  :o
« Last Edit: September 19, 2019, 04:30:15 PM by Paul_B »

jerryp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #10 on: September 20, 2019, 09:47:10 AM »
Thank you. I would appreciate that. In the mean time, I will check out the recommended link.

Cheers -

Paul_B

  • Administrator
  • Hero Member
  • *****
  • Posts: 305
  • Karma: 17
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #11 on: September 24, 2019, 09:22:45 AM »
Morning Jerry,

My BBBW (wireless) has arrived and I've started testing.

Out of box the default Debian Jessie OS (booting off the eMMC) appears to run with no problems.
Note: No modifications were made to the NHD-7.0CTP-CAPE

The NHD cape should be supported out of the box (unless an old version of u-boot get's the way).

For trouble shooting purposes can you please answer the following:

What OS are you running?
What is your 5V power supply rated to?

In the mean time I'll begin testing the images listed in our User Guide via a microSD card.
« Last Edit: September 24, 2019, 10:28:38 AM by Paul_B »

jerryp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-7.0CTP-CAPE - BBB does not start up properly
« Reply #12 on: October 09, 2019, 10:48:45 AM »
Paul,

Here is the OS info..

debian@beaglebone:~$ hostnamectl
   Static hostname: beaglebone
         Icon name: computer
        Machine ID: 4bd52b1b216d4c40a02bb44c887ac3bb
           Boot ID: 900a1815cb6046fe996fed71658994ef
  Operating System: Debian GNU/Linux 8 (jessie)
            Kernel: Linux 4.4.41-ti-r83
      Architecture: arm
debian@beaglebone:~$

My power supply is 5v 2A

-Jerry

 

Beaglebone LCD cape.

Started by vserovBoard Customer Projects

Replies: 5
Views: 13632
Last post January 20, 2015, 10:31:52 PM
by imanpakii
Unable to start NHD-3.12-25664UCB2 OLED display..

Started by Ankush GuptaBoard OLEDs

Replies: 0
Views: 1232
Last post October 18, 2018, 01:43:38 AM
by Ankush Gupta
[NHD-0420CW-Ax3] Start my display in C language

Started by arrgonBoard OLEDs

Replies: 3
Views: 3204
Last post May 21, 2018, 11:18:12 AM
by Ted_M
MOVED: start point of NHD-C12864LZ-FSW-FBW

Started by Ted_MBoard OLEDs

Replies: 0
Views: 630
Last post May 13, 2019, 10:07:48 AM
by Ted_M
NHD-4.3-480272EF-ATXL#-CTP How to Start?:

Started by npnBoard TFTs

Replies: 1
Views: 5245
Last post May 06, 2014, 12:06:15 PM
by Michael_L