Author Topic: damage from reversed power supply?  (Read 2355 times)

wreinhold

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
damage from reversed power supply?
« on: December 28, 2014, 04:22:50 PM »
I'm using a NHD‐0420DZW‐AB5.  I've confirmed the initialization sequence with a logic analyzer but the display is not working.  I originally connected it with VDD and VSS reversed.  Could that have damaged the display?

Michael_L

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 33
    • View Profile
Re: damage from reversed power supply?
« Reply #1 on: December 29, 2014, 04:13:25 PM »
Connecting VDD and VSS backwards could result in a damaged unit.  Of course this is not always the case but in answer to your question, yes it may have damaged the display.  The longer it was connected this way, the more likely it damaged it.  When you say you have confirmed the initialization with a logic analyzer, have you confirmed the values, sequence, and timing?  Are you correctly attempting to write characters to the display?  It may be beneficial for you to try another display if possible.

wreinhold

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: damage from reversed power supply?
« Reply #2 on: December 29, 2014, 09:40:27 PM »
The display is not damaged, just extremely sensitive to timing.  I have it working finally, after many hours of shooting in the dark.  This is my second battle trying to get a Newhaven display unit working (one parallel, one serial) and I've won both of them, but the interface documentation certainly leaves quite a bit to be desired. 

wreinhold

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: damage from reversed power supply?
« Reply #3 on: December 30, 2014, 06:52:28 AM »
I tried implementing the example code Michael has posted on the forum but these displays seem to be very sensitive to timing and the platforms he develops on seem to have the timing characteristics necessary to make the displays work.  They haven't worked for me. 

After quite a bit of trial and error I've gotten this display to work in the default parallel 6800 mode and I've attached a logic analyzer capture file showing signal timing that works to initialize the display and write "Hello" in the middle of the second line of the display.   This file was captured with the Saleae Logic 1.1.34 Beta, which can be downloaded from the Saleae website (http://support.saleae.com/hc/en-us/articles/201589175).  I've had to rename it with a .jpg extension to get the forum software to accept it.  Change it to .logicdata to open it.

You'll notice there is no checking of the busy flag.  I tried but was not able to work out whatever timing is necessary to get a response from the display.  This works without it and unless I run into problems I'm sticking with it.

You'll also notice this allows a lot of time between writes (~1.2 ms).  I'm using the same delay for all commands, so it's likely these times can be shortened for everything except Clear Display.  It's mainly good to know I have a working display.
« Last Edit: December 30, 2014, 07:11:39 AM by wreinhold »

 

Contrast supply for NHD‐24064WG‐ATFH‐VZ#

Started by Shaun_CarawayBoard Graphic LCDs

Replies: 2
Views: 3702
Last post May 19, 2014, 10:01:31 AM
by Shaun_Caraway
NHD‐0420DZW‐AY5 - Power consumption and luminance difference 3.3V/5.0V?

Started by MonkeywrenchBoard OLEDs

Replies: 0
Views: 1404
Last post November 20, 2015, 06:40:16 PM
by Monkeywrench
Newhaven 128x64 ST7565 LCD NHD-C12864WC-FSW-FBW-3V3-M does not power on reliably

Started by adilmalikBoard Graphic LCDs

Replies: 4
Views: 1509
Last post November 27, 2016, 10:09:36 PM
by samuelproulx
NHD-0420DZW-AB5 Excessive Supply Current

Started by peterrashBoard OLEDs

Replies: 2
Views: 2726
Last post May 06, 2014, 12:10:50 PM
by Michael_L
Supply voltage for KZW series OLED

Started by MustardManBoard OLEDs

Replies: 5
Views: 243
Last post August 25, 2017, 08:09:31 AM
by Saurabh_B