Author Topic: NHD-0420D3Z-NSW-BBW-V3_revB has strange behavior through SPI with Raspberry Pi  (Read 319 times)

VATH

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
I'm trying to send commands and characters to the LCD Screen, and instead of recognizing any of the data coming through via SPI, the screen just prints out the same character that doesn't match any form in the datasheet. This printout happens for every byte that is sent from the Pi to the LCD.

On the oscilloscope and other signal analysis tools, the data looks fine. Our clock speed is under 10kHz, there is definitely data being sent from MOSI, and the chip enable matches up.

I suspect this is some kind of timing issue but we can't seem to figure it out. We're currently using the bcm2835 library for SPI. This problem persists for both a Raspberry Pi Zero W and a Raspberry Pi 3B.

Here is a picture of the LCD Screen characters: https://drive.google.com/open?id=1NL5L29cRPE3PIjEKbWjCc4p9CLdEgsyQ

 

RS232 PIC CCS COMPILER COMANDS FOR NHD-0420D3Z-NSW-BBW-V3 ISSUE

Started by DavidVMBoard Character LCDs

Replies: 2
Views: 2138
Last post May 30, 2017, 12:58:32 PM
by DavidVM
NHD-0420D3Z-NSW-BBW-V3 i2c display and Arduino missing characters

Started by 0miker0Board Character LCDs

Replies: 0
Views: 3072
Last post July 06, 2017, 11:05:59 AM
by 0miker0
NHD-0420D3Z - Arduino I2C Address 0x28 SOLVED

Started by andywbBoard Character LCDs

Replies: 1
Views: 133
Last post August 11, 2018, 01:24:36 AM
by andywb
NHD-0420D3Z-NSW-BBW-V3 back-light flickers

Started by rickford66Board Character LCDs

Replies: 3
Views: 4690
Last post May 06, 2015, 08:34:09 AM
by fraryb
Changing the Slave Address with NHD-0420D3Z

Started by alkBoard Character LCDs

Replies: 2
Views: 3702
Last post January 13, 2015, 01:53:20 PM
by alk