Author Topic: Connecting the NHD-0420-CW Display to the Evalboard  (Read 162 times)

LuikardP

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Connecting the NHD-0420-CW Display to the Evalboard
« on: September 20, 2018, 08:46:28 AM »
Hallo Everybody,
i'm trying to connect a NHD-0420-CW Display via I2C to the evalboard NHDev. I connect the the Pins according to the datasheets. See the table below.
Display            Evalboard
1        VSS            1
2        VDD           2
3       REGVdd       37   tied to GND
4       SA0             5
5-6    tied to GND
7       SCL             30
8 and 9 SDA         38
10-15 tied to GND
16     /RES           11
17     BS0  tied to GND
18     BS1  tied to VDD
19     BS2 tied to GND
20    VSS             38
The evalboard starts. I'm able to select the correct Display type but the Display stays black. Is it possilbe to opperate the Display with the Evalboard over I2C? And when where is the error in this assambly?
Thank you for your help
Philipp

Sergio_M

  • Administrator
  • Jr. Member
  • *****
  • Posts: 10
  • Karma: 0
    • View Profile
Re: Connecting the NHD-0420-CW Display to the Evalboard
« Reply #1 on: October 11, 2018, 08:11:06 AM »
Hello,

Unfortunately, the NHDev board does not support I2C interface, you can test in parallel mode to see how the display looks.

 

Blank Display on NHD‐C0220BiZ‐FS(RGB)‐FBW‐3VM

Started by SteveCBoard Character LCDs

Replies: 3
Views: 8065
Last post May 13, 2014, 12:04:36 AM
by SteveC
NHD‐C12864A1Z‐FSW‐FBW‐HTT display clears after draw

Started by EdAverillBoard Graphic LCDs

Replies: 6
Views: 9826
Last post November 07, 2014, 08:25:20 AM
by Michael_L
NHD‐4.3‐480272EF‐ATXL#‐CTP | FAN5333 | BBB | Nothing on the Display

Started by Alias_AliasBoard TFTs

Replies: 1
Views: 6878
Last post September 25, 2015, 03:09:24 PM
by Paul_B
Arduino LCD library not working with newhaven display NHD‐0420H1Z‐FL‐GWB-3V3

Started by c2hollowBoard Character LCDs

Replies: 9
Views: 15580
Last post July 10, 2014, 08:46:06 AM
by Michael_L
NHD-0420DZW-AG5 - Display "sometimes" shows only 2 lines

Started by stylonurusBoard OLEDs

Replies: 5
Views: 9332
Last post June 18, 2014, 10:09:49 AM
by Michael_L