Author Topic: NHD-0216SZ-FSW-FWB incorrect connection  (Read 2800 times)

moeedmughal

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
NHD-0216SZ-FSW-FWB incorrect connection
« on: April 29, 2015, 07:59:20 AM »
Hi everyone,

I was working on a project made by someone else. It has above mentioned LCD display which is used in 4-bit character display mode and interfaced with a PIC microcontroller. The display was working fine. One day, i unplugged interface connectors (4-pin & 8-pin molex) of display to do some work on main board. I re-connect LCD connectors after i finish the work on main board. Unfortunately, I mis-aligned 4-pin (DB7-DB4/LCD pins 11-14) connecter with an offset of one space. I powered on the system and the display was gone. Only background light is visible. Now upon start-up, LCD displays black boxes for a while in upper row and then turns white. My initial guess was that the LCD is broken. I ordered a new LCD and replaced the old one. Still I have no luck with the new LCD. I donít know why it is not working?

I will appreciate your help in this regard. Thank you in advance.

Paul_B

  • Administrator
  • Sr. Member
  • *****
  • Posts: 248
  • Karma: 16
    • View Profile
Re: NHD-0216SZ-FSW-FWB incorrect connection
« Reply #1 on: April 30, 2015, 07:54:15 AM »
Hello,

I recommend testing the continuity of your display and connector using a DMM.

Please let me know the results of your test  :)

moeedmughal

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0216SZ-FSW-FWB incorrect connection
« Reply #2 on: April 30, 2015, 09:52:14 AM »
Thank you to reply. I have checked the connections, they all are ok. I am wondering, if there is any possiblity that microcontroller is broken ?

Paul_B

  • Administrator
  • Sr. Member
  • *****
  • Posts: 248
  • Karma: 16
    • View Profile
Re: NHD-0216SZ-FSW-FWB incorrect connection
« Reply #3 on: May 01, 2015, 08:32:06 AM »
Hello,

It is definitely a possibility, how long did you have the misaligned connector on your PIC microcontroller?

Thanks!

moeedmughal

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: NHD-0216SZ-FSW-FWB incorrect connection
« Reply #4 on: May 01, 2015, 09:17:05 AM »
Thank you for reply. I connected display and power up the system. I noticed the blank display and switched off the system immediately. UART of microcontroller is still working. I verified that throught hyper terminal. I am not sure if the pins connected to the datalines of display are ok ? Is their any way to check them ? You think any misalignemt of data lines can end into broken microcontroller pin ?   

Paul_B

  • Administrator
  • Sr. Member
  • *****
  • Posts: 248
  • Karma: 16
    • View Profile
Re: NHD-0216SZ-FSW-FWB incorrect connection
« Reply #5 on: May 01, 2015, 09:50:04 AM »
Hello,

If you have an oscilloscope handy that will do the trick  ;)

Since the display was operating normally before you misaligned the connector unfortunately it would appear that your microcontroller is at fault.
« Last Edit: May 01, 2015, 04:26:01 PM by Paul_B »

 

SPI connection and initialization of NHD-C12864A1Z-FSW-FBW-HTT

Started by nicoBoard Graphic LCDs

Replies: 1
Views: 2088
Last post April 28, 2016, 08:31:38 AM
by Saurabh_B
SPI connection to NHD-C12832A1Z-FSR-FBW-3V3

Started by raspdroidBoard Graphic LCDs

Replies: 1
Views: 2398
Last post January 29, 2016, 09:29:52 AM
by Saurabh_B
connection

Started by jemontoya333Board TFTs

Replies: 1
Views: 2402
Last post July 15, 2014, 09:03:28 AM
by Michael_L