Author Topic: NHD-1.8-128160EF-CTXI# problem: becomes pale after using it for some time  (Read 2957 times)

fvdhoef

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
For a big project for our customer we used the NHD-1.8-128160EF-CTXI# display.
We have produced about 100 units now. Of these, at least 2 units have a display that have gone without picture (white screen, only backlight is visible) and some displays have become pale (reduced contrast).

We are worried more displays will fail. We are expecting to ship 10k-30k units eventually, but this problem should be resolved first.

The displays are initialized according to the settings given in the datasheet. The displays are powered from a 2.8V rail (both IOVDD and VDD). IO levels used by the microcontroller that drives the display are also 2.8V.

What can be the problem? Is this a quality issue or are we using the displays the wrong way?

Michael_L

  • Administrator
  • Hero Member
  • *****
  • Posts: 356
  • Karma: 33
    • View Profile
I very much doubt this is a quality issue, as we have not heard of this before, and have not seen this in our testing.  Can you send me a schematic showing your connections to the display?  Also, can you send me your initialization and write command/data functions?  If it is easier for you, you may email us at nhtech@newhavendisplay.com with these items.
« Last Edit: November 04, 2015, 07:54:38 AM by Michael_L »

 

NHD‐3.5‐320240MF‐ATXL#‐CTP‐1 Problem with standby mode

Started by guenterBoard TFTs

Replies: 0
Views: 1942
Last post June 16, 2016, 12:14:36 PM
by guenter
NHD‐2.4‐240320SF‐CTXL#‐FTN1 touch-screen problem

Started by hbcelebiBoard TFTs

Replies: 5
Views: 4180
Last post December 10, 2014, 11:19:05 AM
by Michael_L
Working on NHD‐2.4‐240320SF‐CTXL#‐FTN1, have problem in initialization

Started by sli25Board TFTs

Replies: 6
Views: 3794
Last post June 04, 2015, 09:52:25 PM
by sli25
Problem in bringing up NHD‐2.4‐240320SF‐CTXL#‐FTN1 on Renesas RL78/G14

Started by sli25Board TFTs

Replies: 3
Views: 3057
Last post May 28, 2015, 02:59:03 PM
by Michael_L
problem with NHD‐2.23‐12832UCB3

Started by luisvalsecaBoard OLEDs

Replies: 1
Views: 892
Last post January 24, 2017, 02:52:53 PM
by Saurabh_B