Newhaven Display Forum

Newhaven Products => TFTs => Topic started by: jmag999 on August 31, 2015, 08:03:41 PM

Title: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: jmag999 on August 31, 2015, 08:03:41 PM
There is a distinct yellowing on my display.  Not sure why.  All of the colors are there, but there is a yellow tint over areas, especially a band through the middle 1/3 of the display.  Any idea what can cause this?
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: jmag999 on September 01, 2015, 07:03:05 PM
Any help on this?
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: jmag999 on September 01, 2015, 08:38:06 PM
As an update, I also have the NHD-7.0-800480.  I hooked this up just to see, and it does not have the same issue.  Do I have a faulty 5" display?
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: Saurabh_B on September 02, 2015, 07:58:00 AM
Hi,

I was wondering if you could post a picture of the 7" display to see what the original image is supposed to look like, and also if you have tried this with another 5" display.
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: Michael_L on September 02, 2015, 08:29:18 AM
As Saurabh has suggested, please try another 5.0" display (if you have one) to see if it is unique to the one 5.0" display you've tried.  Another thing to try would be inverting your pixel clock polarity (the 5.0" and 7.0" TFTs have opposite PCLK polarities).
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: jmag999 on September 02, 2015, 09:43:04 AM
Thanks.  I did try inverting the pixel clock with no change.  I have 4 more 5" displays on the way.  I will post a picture of the 7" tonight and also report back when the new 5" arrives.
Title: Re: NHD-5.0-800480TF-ATXL-CTP Yellow Tint
Post by: jmag999 on September 06, 2015, 05:13:21 AM
I can confirm that the new batch of displays works fine with no code changes.  The new one is a Rev 14.  The old one does not have a Revision, but is pretty different even down to the flex circuit.