Newhaven Display Forum

Newhaven Products => OLEDs => Topic started by: dannyj on November 12, 2014, 04:53:58 AM

Title: NHD-1.27-12896UGC3, can't write data correctly, 4 wire spi
Post by: dannyj on November 12, 2014, 04:53:58 AM
Hi,
I am surveying a display module, NHD-1.27-12896UGC3. Currently I can only write commands to this controller correctly, Iíve verified sleep-in, sleep-out, display mode all-on, all-off, display mode normal. They are all correct. But when I tried to write a command and then write data to the controller, I found it usually doesnít work. In other words, it just works sometimes.

I am using 4-wire serial mode.
I put my waveform at the end of this mail. This is a Ďset column addressí command with 2 data, 0x14 and 0x17, I programmed. Iíve checked some sample programs, and they set SDIN as high before writing data. Does this make me canít write data into the controller correctly?
Does it need to delay some time between a command issued and start to write data?
Or does my SCLK not support for this display module?

Thanks for your help.

VDD: ~3V
SCLK: 1.5 MHz ~ 500KHz (Those I have tried)

ss-p9: CS#
sclk-p7: SCLK
mosi-p8-sio0: SDIN
miso-p5-sio1: D/C#
 
Title: Re: NHD-1.27-12896UGC3, can't write data correctly, 4 wire spi
Post by: Michael_L on November 14, 2014, 09:30:55 AM
The set_column_address command uses 2 data parameters after you send it to the display.  You would need to setup the address, and issue the write_memory_start command before writing pixel data to the display.  Please refer to the below example code which has examples with the parallel and serial interface of the display:

http://www.newhavendisplay.com/app_notes/Arduino_OLED_12896.txt (http://www.newhavendisplay.com/app_notes/Arduino_OLED_12896.txt)