Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - blaubaer

Pages: [1]
1
Dear Retheesh,

thanks for your immediate help - really fast response!! Nice support forum here!

I'll check and change the initialization sequence and report the result here later.

Regards,
Michael

2
This may take a while - I didn't code it!

I'll come back to you when I got it!

Regards, Michael

3
The text is printed from right to left and in a mirror I can read it...

4
Hi Retheesh,

now basically it works, but characters are mirrored - I will recheck the solder joints....

Regards,
Michael

5
Hi Retheesh,
On the new display (NHD-0420CW-AG3) there are two additional pins:

Pin 15 = CS (Chip Select) Active LOW
Pin 16 = RES (Reset Signal) Active LOW

Have you set these pins?  If not then set CS to LOW and RES to HIGH.
no, but I'll do that immediately!  ???

Thanks so far,
Michael

6
Dear Reteesh,

thanks for the quick response!

The NHD-0420CW-AG3 display is still not working. Let me shortly point out what I did so far:

I've the NHD-0420DZW-AY5 display in use in my application and it's working fine. Now I saw the NHD-0420CW-AG3 within your OLED display product range and would like to take this display, because the pcb and the display itself is smaller and fits mechanically better into my application.

The NHD-0420DZW-AY3 spec says, that the display is by default in 6800-MPU parallel interface mode, so I set the NHD-0420CW-AG3 with connections pin BS0 and BS1 to ground and pin BS2 to +5V into the same interface mode, connected pin 3 to +5V, did not connect pin2, connected RS to D/C (pin4), R/W, E, the data connections and ground to pin 1 and 20.

What did I wrong? Do you have an idea?

Thanks and regards,
Michael




7
OLEDs / NHD-0420CW-AG3 MPU Interface Pin Selection and Power Supply
« on: March 01, 2015, 07:07:12 AM »
Hi,

for 8-bit parallel 6800 interface mode the NHD-0420CW-AG3 display spec shows for pin BS0 = 0, BS1=0 and BS2=1 - can I connect BS0 and BS1 to ground and BS2 to +5V to switch the display into the 8-bit parallel 6800 interface mode? Do I need pull up/pull down resistors - with which value?

For +5V power supply I've to connect +5V to pin 3 and let pin2 without connection, right?

Thanks and regards,
Michael

Pages: [1]