Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - samuelproulx

Pages: [1]
1
Graphic LCDs / Re: NHD-C12864WC-FSW-FBW-3V3-M random pixels at init
« on: November 28, 2016, 09:18:20 AM »
I was able to clear the screen after all and there are no random pixels.

Although now my issue is that when I write black pixels to the lcd, the entire column goes white (as you saw on the image). Is this also due to contrast? I have it set to the value recommended in the datasheet init, so 0x10 (16/64)

2
I had exactly this problem with this exact GLCD ! On the VREG pin, you should be getting 10.5 volts resulting from the step-up circuit which supplies the LCD's contrast. When mine was not working properly, it was also around 2 volts.

Like said before, make sure you put a delay, it is quite important I believe. I also noticed your initialization sequence differs slightly from mine.

Assuming you followed the model initialization sequence as written in the datasheet, your first byte, 0XA3, seems incorrect... this GLCD requires a 1/9 bias , where as you seem to be putting it at 1/7 (not sure if this would issue that problem though) .

Again assuming you followed the datasheet model, your last byte in the initialization is 0xB0 . Mine is set at 0xAF in order to turn on the GLCD, perhaps it is not on?

The datasheet also puts a delay between the moment you set A0 for command or data and the first byte you send to the GLCD, try putting a delay between 2 and 20 ms , like this:

A0 Pin = 0 ;
delay_ms(2 - 20 ms)
data

Hope I could be of help! I've also been struggling with this glcd. I have a different issue to resort now though.

3
Graphic LCDs / NHD-C12864WC-FSW-FBW-3V3-M random pixels at init
« on: November 27, 2016, 09:01:06 AM »
Hello!

I am using a  NHD-C12864WC-FSW-FBW-3V3-M graphic display and at the initialization (which I followed the datasheet to do) , there are random pixels appearing a little bit everywhere on the screen. I am not sure for what reason this would happen, so I figure maybe someone has had this issue before?

And we can also see on the lcd that the lines where the pixels are printed, the contrast seems different as well?

What am I doing wrong or am I missing something?

Thank you for any help ^_^

Here is a picture of it : http://i.imgur.com/2M7B1oM.jpg

4
Hello,

Alright I know it is a little late to reply, as this is over a year ago, I totally forgot about the post.

But I did manage to figure out the problem.

After issuing a command to change the contrast, I believe the problem was that it requires that you leave a certain delay AFTER issuing the command and not before, to give it time to do the change and all.

IF I remember correctly...

5
Character LCDs / NHD-0 420D 3Z- FL-GBW Backlight brightness won't change .
« on: November 14, 2015, 03:39:49 PM »
Hello

In the light of a recent project, I was trying to adjust the backlight brightness of a NHD-0420D3Z-FL-GBW display through coding , but even with the commands specified in the datasheet, I am unable to change the brightness.  Here is the section that adjusts it in my code :

delay_ms(200);
putc(0xFE);
putc(0x53);
putc(0x08);

. . .

Anyone have any idea's as to why it won't change? I am stumped. I did manage to make it change before, and when that happened I was not able to change it back again.

Thanks

Pages: [1]