Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - nandishsg

Pages: [1]
1
I am having 3.5" Graphics LCD from Newhaven Display part #9950DPTP035H-01 with Cap TP.   

I want to interface this LCD having ST7789s graphics with iMx6q Sabre Automotive Board running linux kernel. I am writing device driver for to initialize the LCD.  For this i referred the st7789s 2.4inch LCD document for initialization of LCD,I assume that IM3 is internally connected to GND. Then I followed 8 bit parallel interface mode i.e IM[3:0]=0000, Then i assume that IM3 is internally connected to VDD then in tried IM[3:0]=1001 also but i am not getting the any result on Display.

I am sending all exactly same command which are given in the example code given on your website for ST7789s graphics controller.

Also I observe that during initialization LCD sinks around 60uA of current for short duration and later it sinks around 20uA.

Can I have some pointers from your side. What could be wrong in this case.

It would be great if you could send us any application note with Hardware configuration and example code for my LCD.

Your help would be appreciated.


Thank You!
nandish  sg

2
Hi All,

I want to interfacing the st7789s 3.5 inch lcd with iMx6q Sabre Automotive Board with parallel RGB565, My board have parallel interface so for that first i would need to initialize the LCD,So
I am Facing the problem with interfacing the st7789s driver 3.5inch lcd with iMx6q Sabre Automotive Board, My doubt is
(1) Where to connect the IM3 it is not mentioned in the Datasheet.

I tried the initialization of lcd with example code from Newheaven Display(http://www.newhavendisplay.com/app_notes/2-4TFT_ST7789.txt) but its not working to me,
I assume that IM3 is connected to LOW(Ground) internally then i tried the initialization of LCD with following mode select (a) [IM3:0] =0000
(b)[IM3:0] =0101  (c) [IM3:0] =0110 then also its not working to me, Then

I assume that IM3 is connected to HIGH(VDD) internally then i tried the initialization of LCD with following mode select (a) [IM3:0] =1001 it is also not working to me, 
can you any one suggest me how to initialization of this LCD and If Any more input is need from my side please let me know,

Thanks In Advance

Nandish SG
                                           

Pages: [1]