Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - fortey

Pages: [1]
1
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 09, 2015, 02:13:26 PM »
Thanks Retheesh!

I was choosing the D/C line before entering the data. The display works properly now!

2
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 05, 2015, 05:25:48 PM »
Thanks Ratheesh.

WR# starts HIGH, D/C# is selected (starts HIGH or LOW depending on command or data), WR# goes LOW, Data goes in, WR# goes HIGH. Of course with appropriate delays in between.

3
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 05, 2015, 04:10:14 PM »
I'm using the sample code given at the end of the datasheet. The only different is that I've added delays after each command and data function.

4
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 05, 2015, 02:48:22 PM »
Nope the display is still the same. We are only writing to the display, and there is no info about what to do with the E/RD pin during the write cycle. Can we just tie that high?

5
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 05, 2015, 01:08:56 PM »
On page 15 of the datasheet http://www.newhavendisplay.com/specs/NHD-0216CW-AY3.pdf

The 8080-Series doesn't have timing information about the Enable(/RD) Pin. Also does the /CS need to be toggled in this case? Or can we keep it tied low?

We are ONLY to writing data to the display.


6
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 05, 2015, 12:42:19 PM »
Yes the Chip Select pin is tied to ground.

7
OLEDs / Re: NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 04, 2015, 05:53:24 PM »
BS2 = high
BS1 = high
BS0 = low
DB0-DB7 connected to MPU
R/W connected to MPU
RES connected to MPU
D/C connected to MPU
VDD connected to 3.3V
E was tied HIGH (made mistake on previous post) currently working on connecting to MPU

8
OLEDs / NHD-0216CW-AY3 8-bit Parallel 8080, Text on Display Issue
« on: March 04, 2015, 04:55:54 PM »
Hey,

For the 8080 Series running 3.3V, does the Enable(/RD) Pin need to be toggled high -> low? Right now I have it tied to ground, but whenever I update my code, the text starts printing from right to left and the text is mirrored. But when I reset the power, the text prints correctly. However, the first 4 text doesn't appear i.e. instead of "TESTSTRNG" it'll print "STRNG" (I'm assuming it is a timing issue). Currently, I am trying to get the display to show all blocks, but my display is showing "alpha" (ROM C) and only displaying it on the top row. I'm using the sample init code provided in the datasheet.

/CS,/REGVDD are tied to ground.
edit: /E(/RD) tied high

Thank you

Pages: [1]