Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - moeedmughal

Pages: [1]
1
Character LCDs / Re: NHD-0216SZ-FSW-FWB incorrect connection
« on: May 01, 2015, 09:17:05 AM »
Thank you for reply. I connected display and power up the system. I noticed the blank display and switched off the system immediately. UART of microcontroller is still working. I verified that throught hyper terminal. I am not sure if the pins connected to the datalines of display are ok ? Is their any way to check them ? You think any misalignemt of data lines can end into broken microcontroller pin ?   

2
Character LCDs / Re: NHD-0216SZ-FSW-FWB incorrect connection
« on: April 30, 2015, 09:52:14 AM »
Thank you to reply. I have checked the connections, they all are ok. I am wondering, if there is any possiblity that microcontroller is broken ?

3
Character LCDs / NHD-0216SZ-FSW-FWB incorrect connection
« on: April 29, 2015, 07:59:20 AM »
Hi everyone,

I was working on a project made by someone else. It has above mentioned LCD display which is used in 4-bit character display mode and interfaced with a PIC microcontroller. The display was working fine. One day, i unplugged interface connectors (4-pin & 8-pin molex) of display to do some work on main board. I re-connect LCD connectors after i finish the work on main board. Unfortunately, I mis-aligned 4-pin (DB7-DB4/LCD pins 11-14) connecter with an offset of one space. I powered on the system and the display was gone. Only background light is visible. Now upon start-up, LCD displays black boxes for a while in upper row and then turns white. My initial guess was that the LCD is broken. I ordered a new LCD and replaced the old one. Still I have no luck with the new LCD. I donít know why it is not working?

I will appreciate your help in this regard. Thank you in advance.

Pages: [1]