Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jglledo

Pages: [1]
1
OLEDs / Re: Problem with NHD 0420CW AY3 Display
« on: October 28, 2015, 03:47:12 AM »
Hi,
the slave address I am using is: 0x3C as SA0 pin is connected to ground.
b7 b6 b5 b4 b3 b2 b1           b0
0   1    1   1   1   0  SA0=0  R/W#
In the initialization sequence I thin I do enable the internal regulator, as I send next commands:
 command(0x2A)
 command(0x71)
 data(0x5C) ---> this is to enable the internal regulator for 5 volts, isn't it?

In the case of sending a command I send next I2C signals

0x3C | 0x 80 | Command byte
start 0x3C ACK stop | start 0x80  ACK stop | start Command byte ACK Stop

In the case of sending a data byte I send next I2C signals
0x3C | 0x 40 | data byte
start 0x3C ACK stop | start 0x40  ACK stop | start Data byte ACK Stop

I have also tied pins that were not connected to ground.
At this moment I don't know if I have damaged the display, because now I am not able to talk to it by I2C...


2
OLEDs / Problem with NHD 0420CW AY3 Display
« on: October 27, 2015, 05:37:53 AM »
Hi,
I am currently working with the NHD 0420CW AY3 Display using I2C protocol. I am receiving ACK responses, but in spite of that my display still remains turned off.
I have tried with the init sequence listed in the datasheet example.

I have some doubts about some pin connections, when using 5volts mode, I write below my connection scheme:
 - 1 (VSS) -->  Ground
 - 2 (VDD) --> 5 volts
 - 3 (REG_VDD) --> 5 volts
 - SA0  --> Ground
 - 5 to 6 Not connected
 - 7 --> SCL
 - 8 and 9 tied together ---> SDA
 -10 to 15 Not connected
 -16 (RES) --> 5 volts
 -17 -19 ---> Ground - 5 volts - Ground (I2C Mode)
 -20 --> Ground

**Should I use any pull up resistor for SDA /SCL? (which value) ?

Any suggestion?

Pages: [1]