Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - gab_electro

Pages: [1]
1
Character LCDs / NHD-C0216CiZ-FSW-FBW-3V3 not working
« on: October 21, 2016, 02:16:23 PM »
Hi,

 I'm trying to get the NHD-C0216CiZ i2c display to work with an Arduino leonardo, but can't get any results. the wiring is as follow

RST: pulled high to 3.3V with 4.7K resistor
VDD to 3.3V
VSS to GND
Vout connected to VDD through a 1uF cer cap
C- an C+ connected together through a 1uF cer cap

SDA and SDL connected to the 5V i2c bus through a level shifting circuit as describe by application note AN10441 fron nxp semiconductor :
http://www.nxp.com/documents/application_note/AN10441.pdf

I tested the i2c bus and level shift circuit by connected other i2c device both on the 3.3v and 5V sides and they work correctly( mcp9600 tested on 5V side and DAC6573 tested on 3V side)

The display backlight is turn on, but I don't see any other sign of activity on it. I tried to reset it  by pulling RST low and it doesn't change anything
The display doesn't acknowledge the i2c adress. Tried both (0x7C and  0x3E). I can clearly see the master sending  the b0111 1100 adress byte  but the sda lines then stays high with no aknowledge.

I tried varying the SCL speed down to 15kHz and  8kHZ with no results.

I also tried ignoring the NACK and sending the rest of the initialisation routine. I used the code posted on your forum here:
http://www.newhavendisplay.com/NHD_forum/index.php/topic,111.msg409.html#msg409
That does'nt work.

I noticed that the sda and scl lines get pulled down from 3.3V to 2.1V when I connect the display. I don't no why it does that.

Does someone have an idea of what could be the problem?

Pages: [1]