Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - M_DeVries

Pages: [1]
1
Character LCDs / Issues upgrading to NHD-0220D3Z-V3
« on: April 22, 2014, 01:55:18 PM »
I have a device that currently uses the NHD-0220D3Z display (Rev 1.0).  As that product is no longer available, I am upgrading to the NHD-0220D3Z-V3.  As far as I can tell, this should be a more-or-less drop-in replacement, with little to no work on my end.  Unfortunately it has not turned out that way.

Comm setup:  RS232 @ 9600 Baud.  I have both R1 and R2 as open connections.

When I connect a -V3 display to my device, I get what seems to be a stream of characters, usually non-English, written to the display.  I strip down my code to do nothing (I do set-up my UART for the comm, but I never write anything to the display) and I get the stream of characters.  I change it to display just a single letter (e.g. "A") or send a single command (I've tried clear screen, display baud rate, set contrast and set brightness, together and individually) and I still get a stream of characters.  For each test, I was able to plug in my original display and always got the expected results (the character was displayed or the command was followed).

I found an engineering notice from 05/22/2012 that says something about a firmware update that may be incompatible with customer code, but no details on what is incompatible.  Also, the datasheets for the two displays are nearly identical with only a few minor differences (e.g. -V3 typically draws 35 mA vs 34 mA for the original).

Any thoughts on what to check would be appreciated.

Thanks,
Matt

Pages: [1]